ASUS RT-AC88U WiFi and AirPrint wireless printer problem solution

The ASUS RT-AC88U is a pretty awesome router. However, out of the box, it’s a bit finicky if you try to print to it via WiFi or Apple’s AirPrint. It doesn’t seem to want to maintain the connection. I stumbled across this somewhat cryptic post and the suggested changes have solved my issues–at least so far. Here are the steps with a little more detail:

1. First log into the router’s settings.

2. Choose Wireless > Professional tab

3. Make the following changes:

-Modulation Scheme: Up to MCS 9 (802.11ac)
-Airtime Fairness: Disable (NOTE: According to one reader, this is the only change that matters, so try this first. Thanks Dan CC!)
-Multi-User MIMO: Disable (Note that this was already disabled by default for me)
-Explicit Beamforming: Disable
-Universal Beamforming (5 GHz only): Disable

Click Apply button.

4. Each of the Bands (i.e., 2.4GHz and 5GHz) have their own independent set of settings on this page. So, change the Band and repeat Step 3.

5. Finally, change the Control Channel to a specific channel (i.e., something other than Auto). Again, apply the change for one band, change the Band setting, and apply the change for the other band. (NOTE: as hellojohnbuck points out in the comments, printers generally only use 2.4GHz, so you probably only need to change for that band.)

 

I’m not sure what real-world impact changing these settings has on the router’s performance; however, I haven’t really noticed any significant difference…other than my printer works wireless now ;-)

NOTES:

Matt S commented below that he disabled a new setting, “Target Wake Time” (Wifi > General), that was causing his printer connection to timeout.

Comments

Duane
Reply

Not only did that fix the AirPrint, it also fixed a connection issue with my thermostat I couldn’t figure out. Much very much obliged!

spice3d
Reply

Good to hear Duane. You’re quite welcome.

Mike Grilz
Reply

I have the ASUS AC-88U and have a question related to internet speed. Over the past 3-4 days I have suddenly started getting erratic drops of the internet. Only last a few seconds but affects things like streaming music or Zoom meetings. I have Suddenlink cable with their 400MB plan. During these last few days I’ve done random checks of speed on the 5G side. At times I am getting download speeds of a little over 400, but I might check 2 minutes later and am getting less than a 100, or at times will just freeze and I get no speed test. I have rebooted all my equipment many times, might work ok for a bit and then issues again. Have also seen messages pop up on my phone saying my “ssid” does not appear to be connected to the internet. I had Suddenlink out yesterday and all he did was try to tighten all the connections on routers, modems etc. and said all was fine so it could be my wireless router. I don’t want to buy that but would like to know if there is a way to determine if it is my router or their service. Any thoughts?

Silver Hau
Reply

Thank you very much! Just changed the Airtime Fairness and I can Airprint now. I had issue since last year when i changed my ASUS router from very old one to AC3100. This is the only website that works! Bookmarked.

spice3d
Reply

You are so welcome Silver! Happy to help.

Matt S
Reply

Many thanks for this. I have the Asus RT-AX88U and whilst these settings had been mostly working for me, I’d found that on the most recent firmware update, they’d stopped. I kept not being able to print. Except, the printers always started again once I’d changed a setting (whatever setting I changed: I tried a diff one each time and each time it worked, and then stopped some time later).

After a bit more digging I found the culprit for anyone else with this issue… “Target Wake time”

The Asus AX router has an “Target Wake Time” function in Wifi >> ‘General’ for the latest IoT devices to help conserve power. It has this option for both the 5Ghz and 2.4GHz bands. However, it seems to confuse my printers on the 2.4GHz band and so whilst they appeared connected, they got confused and timed out.

I’ve disabled “Target Wake Time” for the 2.4GHz band (left it on the 5GHz) and now the printers don’t drop out and everything seems to work as they should. I haven’t yet tried re-enabling the settings in the original blog post yet to see where Asus is up to on this front, but will do in due course.

Hope this helps someone!

Matt

Tom Hesselman
Reply

I’m not sure how you figured this out but it works. I hope people can find this when they’re having Airprint issues with this router. I fiddled for weeks before finding this. I knew it had to be the router because my old Asus router worked with the same printer but how to know what to do to fix it. This IS THE FIX. Don’t need the beam forming stuff, at least I didn’t!! Thanks a bunch!!

spice3d
Reply

You’re welcome Tom. Happy to help.

Ken
Reply

I didn’t change any of the Beamforming settings due router to wifi device performance degradation. Just. changing the first to setting resolved my Airprint issues.

Thanks !

spice3d
Reply

You’re welcome Ken!

Jamie Bissonnette
Reply

2 days of anomalies have been resolved with this guidance. I am left to wonder why Asus maintains the defaults that they do. This caused all sorts of problems not only to Airprint (bonjour) functions, it also will mess with Sonos setup/detection, Honeywell Wifi thermostats to name but a few. Thank you.

spice3d
Reply

You’re welcome Jamie. I totally agree. They need to change the defaults.

Leave a Reply to Andreas Cancel reply