Water Softener: Fix a flooded brine (salt) tank that doesn’t drain

I have literally spent weeks trying to fix a flooded brine tank in my Kenmore water softener. It took me a while to understand how the darn thing worked, but once I figured it out, my problem and, more importantly, the fix seemed obvious. NOTE: I’m pretty sure that most water softeners work very similarly, so even if you don’t have a Kenmore, the information here should be helpful.

Link to my YouTube video with the basic steps

Very Simple DIY Repair

When I first set out to repair my water softener, I was expecting to find a complex set of pumps and valves and such. I was surprised to find none of that. The whole thing just uses water pressure to do it’s magic of passively circulating water around. The only mechanized part is a clock-like component whose purpose is to change the flow of water for the various connections. If that part is working, nearly everything is easily self-serviceable without using any special tools.

It’s sort of easy to understand how the device can fill and flush out the various tanks with water. What amazed me was the ingenious way it uses water pressure to create a vacuum to suck the water from the brine tank reversing the flow of water using the same hose! To me, this is the most complex portion of the water’s journey through the system and probably why most problems occur here.

Handy Tools

One thing you will definitely need is a small paperclip or toothpick. I would also highly recommend a headlamp. This way you can use both hands and still have good light to see inside the mechanism. I use the HEIMDALL Led Headlamp Flashlight. The light tilts up and down and is very compact. Comes with a nice case and only uses a single AA battery.

Fill and Brine Stages

Now, there are several stages to the water softening process, but the two most important with respect to the flooding problem are Fill, which just fills the brine tank with water, and Brine, which moves the salty water from the brine tank to the resin tank where the water “softening” happens. (If you want to know more, the How Your Water Softener Works section in the user guide was extremely helpful.)

venturi assembly

Examining the Venturi

There is an indispensable interactive animation at kenmorewater.com [NOTE: The original site stopped working. This one does not work in Chrome]. Click on Symptoms and then Check Flooded Salt Tank. The animation will walk you though a bunch of steps; however, it’s likely that the problem is in the venturi assembly so, click No when it asks if you cleaned it.

Basically, you first bypass the softener by pushing in the Bypass Valve plunger, take the hood off the water softener and then disassemble the venturi housing. You’ll want to inspect and clean the nozzle and venturi parts inside. I’m not going to go thorough all the steps since the animation covers it quite nicely, but I’ll elaborate on some important things that are missing or glossed over.

The venturi housing top just unscrews. No tools needed. Hold the base so you don’t crack anything, while twisting counterclockwise. A paperclip and small screwdriver are helpful to get the some parts out without dropping and potentially losing them. You may want to take photos with your phone for reference later.

The venturi housing the inside parts

IMPORTANT: The two small black flow plugs are different! Make sure you keep track of them and remember which goes where! There is writing imprinted on the plugs to help you identify them. There is also a tiny screen screen filter which often gets stuck to the large gasket, so be careful not to lose it.

In the Brine stage, water is sucked from the brine tank through the same tube used to fill the tank. The way this happens is that water moves through the venturi housing creating a vacuum. You want to make sure no foreign particles are in there messing things up, particularly on the venturi (blue part above). A paperclip can be used to clean the holes on the small black flow plugs. Warm soapy water can be used on all of the parts.

Examine the large gasket closely. Aside from dirt particles messing with the water flow, this gasket is the likely problem for a flooded tank. If it has grooves in it or is falling apart, replace it. I got mine on Amazon for $19. It sits on top of the venturi which has really tiny canals in it and over time the gasket will conform to them creating the grooves. As a result, canals in the venturi will start to close impeding the flow of water.

Put it Back Together

When you reassemble the venturi housing, make sure you do it in the correct order and get the small black plugs in their correct spots. As stated above, The flow plug with the smaller hole goes in the venturi (blue part below) and the other one goes in the bottom of the housing.

Nozzle and venturi part
The plug above goes into the nozzle and venturi. (Note that mine had 28 on it, not 25)
The plug above goes into the bottom of the housing.

I had a lot of water in the tank so I siphoned most of it out. I tried to use a cut off garden hose, but got sick of all the salt water in my mouth so I bought this siphon.

What Else Can it Be?

If it isn’t a bad gasket or dirt in the venturi, make sure the tube to the brine tank is clean and doesn’t have kinks or is broken. Also, take the float mechanism out and make sure it’s working properly. This is all covered in the animation. (This was another helpful site)

The mechanics of a water softener are pretty straight forward once you understand how it works. As long as the main clock mechanism is working, it should be pretty easy to fix. I hope this little post helps someone! If you have questions, please post comments, but I’m not plumber and don’t know much more than what I’ve written above ;-)

 

 

Comments

Brian Boyle
Reply

now?Due to complications he had to empty my water softener and right not it is just as it came from the dealer. What do i do to get it going again?

Brian

Troy
Reply

Well I have an older GE Smart Water conditioner, and have a few problems with the water not being siphoned out of the brine tank. Here a few years ago, I have replaced all of the gaskets and plugs, taken apart the entire valve assembly replacing any O-rings and just making sure it was completely clean. I have found that if I place 2 sets of O-rings on each of the venture inlets, I get a better seal for suction. I have also found the rubber seal in the bottom of the suction/fill tube does gets stuck in the closed position (when it is filling) and then won’t drop down allowing any of the brine to be siphoned out. I have also found that if I don’t place the smaller flow plug in the venture, I also get better siphoning out the brine tank. Once I got these kirks figured out, it works perfectly.

Alison
Reply

Replacing our gasket (part # 7204362) purchased via the Amazon link above worked for our Kenmore 350 model 625.383500. Incidentally, we discovered we were missing a flow plug so we replaced those as well (1148800) and (0521829). If I had to do it over, I would have just ordered the whole Venturi and nozzle assembly (7238450). It only costs a few dollars more and you’d have all new parts.

spice3d
Reply

Great!

hienthuong56789
Reply

I know some people might be impressed with the ‘venturi’ system, but it is old school and -extremely- wasteful of water. A simple modern pump would be more reliable and efficient. Moreover, in 2019 (and for the past 20 years, at least) the brine tank should have a sensor & alamr to prevent overfilling and flooding of the floor or basement… designers are lazy. Brine and backwashing water should now be done by a pump, not a venturi.

Joe
Reply

My water tank is filled with water it’s usually filled with salt I’m not sure what’s going on

Steve
Reply

Came across this site a while back. Having the exact same issue. I’ve done everything listed including replacing the gasket etc. My tank still will not drain. When I have the float out and put the tube in water, it does not draw anything out. Unfortunately, the flash animation does not allow me to progress after using the “no” answer for this issue, lol.

Anyone know what to look at next? I do have suction at the venturi if I pull off the tube and place my finger over it. I can also blow through the entire line without issue. Thanks for any insight at all – I’m at the point of calling someone, but need to find a local repair shop that will service these models.

Vin
Reply

Wat if the salts are all bunch up like a block of ice. Then wat will you do?

Jeffrey A Hall
Reply

Take a clean sturdy wood pole and break it up. I use a claw hammer when needed. To prevent it caking like that, give it a good stir every few days. Like a witches brew.

Cameron L Slimp
Reply

Could a bad 7204362 gasket cause water pressure issues as well?

spice3d
Reply

Bypass the softener and see if you still have water pressure issues. I don’t think that gasket, by itself, could cause water pressure issues, but it certainly could be something else in the softener.

Cameron L Slimp

I’ve bypassed it and it’s definitely related to the softener. It’s only 4 years old so I can’t imagine that the resin is bad.

Cameron L Slimp

To be clear, my tank is holding water as well so I was hoping that the gasket would fix both issues.

spice3d

So hard to say. Wish I could be more help.

Anthony Burrell
Reply

my brine tank was always full and little softening taking place. my problem was salt buildup in the drain line. duh.

Ken Elliott
Reply

After I put the Venturi assembly together I found that there was too little water going into the brine tank during the “fill” cycle. I looked at the kenmore manual and found that you have the numbers on the plugs reversed. The larger plug (0.3 gpm or part # 1148800) goes in the bottom of the housing. The smaller plug (0.15 gpm or part number 7084607) goes into the nozzle and Venturi. After switching them, the fill cycle allowed the correct amount of water into the brine tank. Also I just bought that gasket you mention from Amazon and found it is $12 and change. Thanks for a very helpful article.

spice3d
Reply

Thanks Ken. Yeah, I think i got it backwards in the YouTube video, but correct in my blog post.

Bill Huston
Reply

You got those images from the really slick and helpful animation on kenmorewater.com but now the web page is gone! Nothing. Do you know how I can find that animation again? Thanks.

spice3d
Reply

Dang it! No, I don’t know how to access that animation now that the site is gone. Sorry Bill.

Billy McKeever
Reply

I’ve cleaned out the brine tank completely, it was packed solid in the bottom. Should I put some salt in the tank and/or water?

vikas singh
Reply

Hi, my brine tank is full too. How did you clean it?

Nicholas Yousif
Reply

can u link for me were to buy a new gasket. I cant find it on amazon

spice3d
Reply

Nick, it’s in my post above. Click where it says “on Amazon for $19”

Leave a Reply to Alison Cancel reply