Certain keys on Logitech K480 Bluetooth keyboard not working fix!

I had some expiring Dell reward points and spent in on a Logitech K480 Multi-device Bluetooth keyboard. What’s unique about this keyboard is that you can switch it between up to three devices using a little knob. This means I can use one keyboard with my Windows PC, my iPhone and an iPad.

The first  thing I paired it up with was my iPhone 6S. Immediately, I ran into a problem: certain keys did nothing when pressed (‘ < \ and |). Oddly, they worked fine if I paired the K480 with a Windows PC and even an iPad. Since it worked with an iPad, it couldn’t be an issue with iOS.

Eventually, it occurred to me that I didn’t use third-party keyboards on the iPad, but did on the iPhone 6S. I disconnected the keyboard from the phone and switched the selected on-screen keyboard to the default Apple keyboard. Then, I reconnected to the K480. This did the trick and the keys started working!

I’ve seen the problem posted several times, but haven’t seen this solution anywhere so hopefully this will help some folks.

While I’m here I’ll mention a few things about the K480:

  • It’s pretty big and relatively heavy. You could tote it around, but it’s not particularly portable.
  • The keys are very noisy so if you want something for a quiet environment, look elsewhere.
  • It switches between devices very nicely and smooth.
  • Pairing is super easy.



Leave a Reply