Tire pressure sensor issue for 2008 Lexus RX350

The tire pressure monitor sensor (TPMS) light had been illuminated for a while on my 2008 Lexus RX350 even though all my tires, including spare, were at or higher than the recommended PSI. I scoured the web for a solution, but it took me a long time to sift through the many forum posts and actually find one.

There’s actually many things that can cause the problem. I’m posting the information below to help out the legions of other RX350 owners looking for a nice concise solution to this irritating problem.

1. Make sure the Main/2nd button, underneath the dash on the passenger side, is set to Main (this is the “out” position of this push button.) This can easily get accidentally pushed in by a passenger’s leg. If you are wondering what this switch does, it’s for people that have two sets of tires with pressure sensors on both sets. This might be for a set of snow tires, for example.

2. Inflate all tires to at least 33psi.

3. Make sure you inflate the spare tire too.

valvestemcaps

4. Make sure you have aluminum valve stem caps on all tires including the spare. Don’t use plastic or non-aluminum metal caps. Other metals can actually fuse to the stems over time! You can probably get them at the dealer, but I bought some on Amazon like these.

5. Press the TPMS reset button underneath the dash on the driver side. There are two buttons near each other and it’s the one on the left.

Well, I hope this information helps someone. The Main/2nd switch is what tripped me up and it wasn’t mentioned on most of the forum posts I read.

UPDATES:
2016-01-06 – Added picture of the Main/2nd button.
2015-07-20 – Since the Main/2nd button is often the culprit, I moved that from #5 to #1 :-D
2015-10-12 – Amazon doesn’t carry the original caps I bought so I substituted the link and photo to some similar looking ones.

Comments

Nini
Reply

Omg! Thank you for this post. It’s s life saver

KAILASH R MAKHIJA
Reply

Thanks so much, I had problem with tire TPMS and went to tire place they could not reset went to dealer and the switch was accidently pressed by some one

John Gibson
Reply

Thank you so much! My 07 has had the light on for over 6 months. All tires have appropriate pressure. I finally googled it. Yep, the button was selected to second!

spice3d
Reply

Your welcome John :-)

RW Hollis
Reply

Took my ’08 into my regular service person and he checked the sensors with a device that shows the status of the batteries in each sensor (yup, each TPMS unit has a battery). He found one in the left from wheel that indicated the battery was dead. He suggested replacing all the units, including the spare, with fresh ones. That should solve the problem of the dashboard warning light. I’ll update when the new ones are installed.

spice3d
Reply

I didn’t know that but it make sense that there is a battery involved. Good luck.

Anand
Reply

Thank you so much. The manual is not very clear on the issue of main switch.

Jim
Reply

If main passenger button is out, and all tire pressures (including spare) are set to 35, and low pressure is still on, try this: Deflate “all” tire pressures to abour 23 and then try a reset. If light is out, re-inflate all tires to 35.
If light is still on, you probably have a bad sensor within one of the tires :(

Jim
Reply

I had the same low pressure light and it would not go off after a reset….the passenger side “main” was “in”. After pressing it to “out”, light went off. :)

ernie
Reply

I inflated all 5 tires to 30 psi, the switch from the passenger side is set to main and while I’am depressing the reset button on the driver side, it flashes 3 times followed a two second flash 3 or 4 times and back to flashing light again. What is this mean?

spice3d
Reply

Sorry Ernie. No idea. Hopefully someone with more knowledge will respond.

dan
Reply

the shop couldnt turn my light out after thep replacec one sensor. i found the reset on passenger side and light out now thank you

Phil
Reply

What can I say but Thank you. I got to this late after chucking out $60 on a diagnostic that ended up saying one of the sensor is bad. Then I clicked the Main/2nd switch and problem solved.
Thank you very much any ways. we learn each day.

Jerry
Reply

Same thing happened to me, low tire pressure light came on in my 2009 RX 350, tire pressure checked good (30 psi) on all 4 plus spare, light came on flashing for 3 minutes than stayed on indicating a bad sensor per the owners manual. A Service center said all sensors checked good, was unable to get light off in spite of an hour of trying and told me my tires were shot. Went to Costco, replaced tires, and paid for a service pack for all tires and they said sensor on spare was bad, had them replace it however light did NOT go off. They said that I may need to drive it a while for the computer to reset, didn’t work. Got up next morning, found this blog, yes the switch on the passenger side was in the wrong position, I set it to “main” and after starting the car the light went out in several seconds. Thank goodness for the web, considering 2 service centers could not figure out what took me 5 minutes of time on the web.

Harvey Grimball

Jerry when you set to “main” is the button out or in?

spice3d

Out is MAIN and In is secondary set.

karen keller
Reply

Thank you so much and a miracle I stumbled on your original post. Our TPMS light came on while driving and a very long distance- the pressure should be higher due to the heat and high speed driving. We added air at the next stop and still on. Puzzled… I searched and searched and found your article and it was INDEED the stupid little button on the passenger side that was pushed down into the 2nd position that caused the lights to come on. I say fire the engineers in Japan who designed this vehicle and the ridiculous locations of some of them! THank you!

Tom Outt
Reply

amazing age we live in. So blown away with the technology we have access to. Thanks to you and everyone else that’s spreads their knowledge. Happy New Year .

oh yeah the light came on 25 miles after replacing 4 tires. had to put some air in the spare tire . pressure was too low. 2007 400 H

Leave a Reply